VW Jetta MKIII/MK3: fix for the Aftermarket Radio Problem|Volkswagen Bora
+ Reply to Thread
Results 1 to 6 of 6

Thread: fix for the Aftermarket Radio Problem

  1. #1
    AllShoNoGo Gargamelmk2 is on a distinguished road Gargamelmk2's Avatar
    Join Date
    Jan 2009
    Location
    Summerside,Prince Edward island. C-A-N-A-D-A
    Posts
    2,467

    Default fix for the Aftermarket Radio Problem

    TAKEN FROM ANOTHER SITE


    The "Aftermarket Radio Problem"
    Background:
    Somewhere between 1997 and 1998, VW and Audi started using diagnostics-capable radios in most of their models. That means the dealer's scan tools (and our own VAG-COM system) can talk to the radio. Why? So you can set various options, like whether a CD player is connected, whether there's an amplified or conventional antenna, and so on. In addition, these radios constantly monitor their speaker outputs and if you have an open or short circuit to one of the speakers, even a momentary one, they will record a fault code.

    The problem is, VW brought the "K-Line", the wire on which all of the control modules in the car communicate with the scan-tool to a pin in the connector on which older radios used to put +12 back into the harness. (We're not sure whether this was for antenna power or as an amplifier turn-on or what). So if you were to take the non-diagnostics capable radio out of a 1997 GTI and put it in a 1998 (where there should be a diagnostics-capable one), it fits perfectly, plugs right into the harness, but the K-line ends up shorted to +12!
    Aftermarket Radios
    Now people hardly ever put older stock radios in newer cars. What they often do is install better after-market radios. And they most often do this by using an aftermarket adapter-harness which plugs right into the car's harness, so they don't have to cut up the car's harness. Trouble is, some of the aftermarket harnesses faithfully reproduces the older, non-diagnostics radios with a loop of wire between +12 and the pin where the K-line is on newer models. So you install your fancy new radio with one of these and everything works fine until.. somebody plugs in a scan tool.
    The Problem
    Nothing in the car cares if the K-line is shorted to +12. The K-Line is not used for intra-vehicle communications. But a scan-tool initializes a communications session by pulling the K-line to ground. The K-line is supposed to have some voltage on it, but through a high-impedance source. If the K-line has "hard" +12 on it, something has to give! What "gives" is usually the scan-tool's output driver for the K-line. And fixing a VAG-1551/1552 with a blown K-line driver is expen$ive! But the ISO-COM PC<->Car interface adapter that we provide with our VAG-COM software has a small user-replaceable fuse protecting the K-Line output driver, and there's a spare fuse taped under the lid of the little box. No big worries there..:-) Our other interfaces use output drivers that are thermally protected against shorts. They don't need a fuse. If you plug them into a car with the K-line shorted to +12, they simply won't work in that car, but it won't hurt them either.
    The Dealers
    Some dealers will refuse to scan any car that has an aftermarket radio. Since most dealers have "killed" a few of their very expensive scan-tools, I can sort of understand why. The best solution: Buy our VAG-COM software and scan it yourself..:-) If you can successfully scan the car with VAG-COM, you know it's safe -- and can likely convince the dealership that it's safe too.
    Test for this problem yourself
    You can test for this problem yourself without removing the radio. First, if your car is a 1996 or earlier model, don't bother -- the K-Line doesn't go to the radio harness and there is no possibility that that the car has this problem.
    If you have a Vag-Saver : Simply turn the ignition ON and plug in the Vag-Saver. Look at the LED. Green is OK, Red is not OK.
    If you have a volt-meter: measure the voltage between pins 4 and 7 of the diagnostic connector with the ignition and radio turned ON. If it's under 9V, your K-line is fine. If it's over 9V, the results are inconclusive. You'll need a 1k Ohm (approximately) resistor. Put it between pins 4 and 7 of the diagnostic connector. Now use the volt-meter to measure the voltage between 4 and 7 (in parallel with the resistor). If it's under 1V, you don't have the problem. If it remains near 12V (the resistor will get hot!) you do have this problem and you'll need to fix it per the the instructions below.
    If you don't have a volt-meter: Go to Radio-Shack and buy a 1K-ohm resistor. I think they cost $0.99 for a pack of 5. Temporarily place the resistor between pins 4 and 7 of your diagnostic connector. Ensure it's making contact with both pins. If the resistor gets hot, your K-line is shorted to +12. If it does not get hot, you're fine. Do NOT install this resistor in the port. You are simply using it to check and see if the k-line has +12V. If the resistor gets hot, then pull it out and fix the problem by disconnecting the k-line from the stereo's wiring harness.
    Fix the Problem:
    Remove the radio. Then make the following modification to the car's wiring harness:
    Make sure that the k-line is not connected to anything if you have an aftermarket radio!
    Note: 2002+ "Premium VI" Radio:
    Some 2002 and newer VW's come with the double-DIN "Premium VI" radio. This radio does not have a k-line connection, but rather has a CAN-high and CAN-low. Although the connector is completely different and it shouldn't be possible to have the "Aftermarket Radio Problem" with these newer cars, it would probably be in your best interest to make sure that NOTHING is connected to these pins in the radio harness, if you use an aftermarket radio. The back of the Premium VI radio is shown in the below diagram.
    8 pin multi-connector II

    9 - CAN-Bus plus
    10 - CAN-Bus minus
    If Nissan motorsports is called Nismo, wouldn't Honda motorsports be called Homo?

  2. #2
    Junior Member shakes_101 is on a distinguished road shakes_101's Avatar
    Join Date
    Oct 2010
    Location
    Houston
    Posts
    16

    Default Re: fix for the Aftermarket Radio Problem

    duuuude you are a life saver. I just bought a car and i got a CEL which i couldnt diagnose cus of this lol

  3. #3

    Default Re: fix for the Aftermarket Radio Problem

    It is a nice writeup (I used the same writeup after finding it in Google in the original site last week) but it all can be summed up quite quickly by just saying....

    Don't connect any of the power up with the harness and wire them directly to a source (which there is a very nice source under the dash for this.) Only use the harness to wire the speaker leads.
    2003 Wolfsburg 1.8t 5 sp

  4. #4
    Senior Member JDM_GUY is on a distinguished road JDM_GUY's Avatar
    Join Date
    May 2010
    Location
    San Francisco Ca
    Posts
    984

    Default Re: fix for the Aftermarket Radio Problem

    intersting... maybe Vicky can add this to the master DIY
    Love it or Hate it/Show with a Go/Engineered to leave tire mark on your face

  5. #5
    Junior Member shakes_101 is on a distinguished road shakes_101's Avatar
    Join Date
    Oct 2010
    Location
    Houston
    Posts
    16

    Default Re: fix for the Aftermarket Radio Problem

    ok one problem. lol the previous owner cut the harness. any way for me to test which is the k wire that im not aware of?

  6. #6
    lowness and dopeness Marc1987 is on a distinguished road Marc1987's Avatar
    Join Date
    Jan 2010
    Location
    Rhode Island
    Posts
    4,819
    Blog Entries
    1

    Default Re: fix for the Aftermarket Radio Problem

    not to test, no. you need to find someone who has done it to their mk3, and ask them what color the wire was
    2000 jetta 2.0//all show no go//owned.


    Quote Originally Posted by I4N View Post
    ear sex
    RIP: 1995 black mk3
    build thread

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Volkswagen Forum Volkswagen Jetta Diminished Value Oregon portland oregon seo oregon accident report Diminished Value total loss Google Places Forum Las Vegas Myths Oregon Civil War privacy policy